Advisory

CVE-2026-113499: Cross-site scripting in LiteSpeed Cache

CVSS 7.5 (CVE record)Published Oct 24, 2026Last verified Nov 4, 2026

An unauthenticated attacker can inject malicious web scripts into pages of a WordPress site running the LiteSpeed Cache plugin. These scripts execute in the…

Exploited in the wild
Not reported
Installs not updated
At least 16.45%
Affected and fixed versions
ComponentAffectedFixed in
LiteSpeed Cache (plugin)before 7.9.27.9.2
Run a free scan of your site

The free scan checks what is visible from outside your site. It does not log in, and it cannot confirm on its own whether this specific issue is present.

Summary

This is a Cross-Site Scripting (XSS) vulnerability. It affects the LiteSpeed Cache plugin for WordPress. The vulnerability is patched in version 7.9.2. There is no evidence of active exploitation.

Affected and patched versions

  • LiteSpeed Cache (plugin litespeed-cache): affected before 7.9.2; fixed in 7.9.2

Is my site vulnerable?

To determine if your WordPress site uses a vulnerable version of the LiteSpeed Cache plugin, check the installed version. This process is straightforward and can be completed through your WordPress administration panel.

First, log in to your WordPress administrator dashboard using your credentials. Once logged in, navigate to the "Plugins" section. This is typically found in the left-hand navigation menu. Within the "Plugins" section, locate "LiteSpeed Cache" in the list of all installed plugins. The version number for each plugin is displayed prominently next to its name.

If the version number displayed for your LiteSpeed Cache plugin is earlier than 7.9.2, your site is exposed to this vulnerability. Updating the plugin is necessary to mitigate the risk.

What an attacker actually does

This vulnerability, identified as CVE-2026-113499, arises from fundamental security weaknesses within the LiteSpeed Cache plugin: insufficient input sanitization and inadequate output escaping. Input sanitization is the process of cleaning or filtering user-supplied data to remove potentially malicious content before it is processed or stored. Output escaping involves converting special characters in data so they are displayed as literal text rather than being interpreted as code when rendered in a web browser. The absence of these crucial security measures creates an opening for attackers.

Specifically, the plugin's design includes HTML rewriting routines intended for stylesheet content. However, the plugin fails to restrict these routines exclusively to stylesheet content. This oversight means that these routines can inadvertently process other parts of a web page's HTML. A critical consequence of this failure is that the plugin can remove a quote that is meant to terminate an attribute within the rendered HTML.

When this specific behavior is combined with the plugin's failure to escape comment author output, a path for exploitation emerges. An unauthenticated attacker can submit a comment containing specially crafted HTML. This crafted content includes attributes designed to execute JavaScript code. Because the plugin does not properly sanitize or escape this input, and because its HTML rewriting routine removes a necessary quote, the malicious attributes become active in the page's structure.

If such a comment is published and displayed on a front-end page, the injected JavaScript will execute in the web browser of any user who views that page. This includes visitors browsing the site, and critically, logged-in administrators. The execution of arbitrary web scripts in a user's browser can lead to various malicious outcomes, such as session hijacking, where an attacker gains control of a user's active session; defacement of the website; redirection to malicious sites; or the theft of sensitive information, including administrator credentials. The ability for an unauthenticated attacker to achieve this makes the vulnerability a significant concern for affected sites.

How to detect a compromise

Detecting a compromise related to CVE-2026-113499 involves a careful review of your site's content and behavior for any anomalies. Since the attack vector leverages comment functionality to inject malicious scripts, your primary focus should be on recent comment activity and the rendered output of pages that display comments.

Indicators of a potential compromise may include:

  • Unexpected Browser Behavior: Users, including yourself, might observe unusual JavaScript pop-ups, unexpected redirects to unfamiliar websites, or changes in page content when viewing front-end pages, especially those featuring comment sections. These behaviors suggest that unauthorized scripts are executing in the browser.

  • Suspicious Comment Content: Examine comments within your WordPress dashboard. Look for comments that contain unusual or malformed HTML tags, JavaScript code (e.g., <script>...</script>), or HTML attributes that trigger actions (e.g., onload=, onerror=, onclick=). These might appear within the comment author's name, email, URL, or the comment body itself.

  • Database Inspection: For a more thorough check, you can directly inspect your WordPress database. Access your database (e.g., via phpMyAdmin or a similar tool) and navigate to the wp_comments table (or [prefix]_comments if your table prefix is different). Review the comment_content, comment_author, comment_author_email, and comment_author_url fields for any entries containing suspicious HTML or JavaScript.

To assist with database inspection via the command line, if you have WP-CLI installed and configured for your WordPress site, you can use the following command to list comment content and search for common script indicators: wp comment list --field=comment_content --format=csv | grep -E '<script|on[a-z]+=' This command retrieves the content of all comments and pipes it through grep to search for <script tags or attributes starting with on followed by letters (like onload, onerror, onclick). Any lines returned by this command warrant careful investigation.

Additionally, review your server access logs for any unusual or excessive requests to comment submission endpoints, which might indicate automated attempts to exploit this vulnerability. Pay attention to requests originating from unfamiliar IP addresses or those with suspicious user-agent strings.

How to fix

To address CVE-2026-113499 and secure your WordPress site, follow these steps:

  1. Update the LiteSpeed Cache plugin to version 7.9.2 immediately. This is the primary and most effective remediation.

  2. Ensure your WordPress installation and all other plugins and themes are kept up to date to benefit from the latest security patches.

  3. As a temporary mitigation, if an immediate update to version 7.9.2 is not feasible, consider disabling the affected HTML rewriting option within the LiteSpeed Cache plugin settings. Consult the plugin's documentation for specific instructions on how to manage this option. This temporary step reduces the attack surface but does not fully resolve the underlying vulnerability.

Timeline

Date

Event

2026-10-20

Patch release

2026-10-22

CVE Published

Sources

PowerSEC coverage
PowerSEC detects the affected versions on every plan, and has since October 25, 2026. No PowerSEC firewall rule blocks this attack. Update to 7.9.2 or later to remove the vulnerability.
This record contains material that is subject to copyright Copyright 2012-2026 Defiant Inc. Copyright 1999-2026 The MITRE Corporation
Hacked? Talk to us